Can't save group policy: "The parameter is incorrect"

  • 53 Views
  • Last Post 2 weeks ago
AD4EVA posted this 2 weeks ago

Hi

Running SBS 2011 with a single DC and I am having issues modifying certain GPO settings.

I was going to simply increase the maximum password age to 60 days, and after making the change to the GPO and trying to save, I receive an error:

GPO-errorGPO error screen shot

From the screen shot above, one can see that the file does indeed exist.

To test further I created a new test GPO and tried to enable the same setting and I got the same error.

I can set GPO **Preference** settings OK, such as "Create new folder c:junk", but not the password policy settings (which are domain related), and as the error window shows, something to do with "Security Templates"

As part of log checks I noticed that the File Replication Service was logging a journal wrap error so I fixed this but still the GPO setting, "max password age" can't be set.

I've spent half a day on this and not getting anywhere.  Has anyone got any tips on how best to solve this issue?  Much appreciated.

Thanks

Order By: Standard | Newest | Votes
dloder posted this 2 weeks ago

Use ProcMon and see what error is really happening when attempting to save.
-- dloder.blogspot.com --












On ‎Wednesday‎, ‎June‎ ‎13‎, ‎2018‎ ‎05‎:‎31‎:‎18‎ ‎AM‎ ‎EDT, gordon@xxxxxxxxxxxxxxxx <gordon@xxxxxxxxxxxxxxxx> wrote:













Hi



Running SBS 2011 with a single DC and I am having issues modifying certain GPO settings.
I was going to simply increase the maximum password age to 60 days, and after making the change to the GPO and trying to save, I receive an error:



GPO error screen shot



From the screen shot above, one can see that the file does indeed exist.
To test further I created a new test GPO and tried to enable the same setting and I got the same error.
I can set GPO Preference settings OK, such as "Create new folder c:junk", but not the password policy settings (which are domain related), and as the error window shows, something to do with "Security Templates"
As part of log checks I noticed that the File Replication Service was logging a journal wrap error so I fixed this but still the GPO setting, "max password age" can't be set.



I've spent half a day on this and not getting anywhere.  Has anyone got any tips on how best to solve this issue?  Much appreciated.
Thanks

show

darren posted this 2 weeks ago

Given the “parameter is incorrect” entry, it could mean that your gpttmpl.inf file is corrupt in some way. Try opening it in notepad and see if you see any weird characters or anything out of the ordinary. You can compare it’s structure

to the Default Domain Policy, for example, to see if there is something fishy. Do you have a backup of that GPO?



 

Darren

 

 

 

 

 

show

Close