Pop-up message when creating a GPO WMI filter on 2012 R2.

  • 3.6K Views
  • Last Post 29 July 2015
Milo posted this 28 July 2015

Hi there,
I have created a WMI filer in GPMC, one that I have used many times (to determine the PDCe role holder for purposes of NTP configuration on DCs), but this is the first time I am doing this in an AD built on 2012 R2 (DFL and FFL @ 2012 R2). During the creation of the filter I get the following message:
"Either the namespace entered is not a valid namespace on the local computer or you do not have access to this namespace on this computer. It is possible this is a valid namespace on the remote computer(s). If you wish to use this namespace, press OK. Press Cancel to choose another namespace."
Not seen this before. I have pressed OK and the filter seems to be applying (i.e. showing in GPResult, on the box in question the settings are in the policies part of the registry, etc.).
Is this a bug?
Anything I should be concerned about?
Thanks
Milo

Order By: Standard | Newest | Votes
kennedyjim posted this 28 July 2015

There is another part to that error message:   “It is possible this is a valid namespace

on the remote computer(s).”

 

You created the original WMI on 2008 (for example) and 2008 has that namespace, but 2012R2 does not.  If you hit that same WMI from a 2008 box you won’t get that error. From

what I have seen, no problem, it is just a warning that you might have borked it.

 

 

show

jeremyts posted this 29 July 2015

Maybe you typed something wrong?

 

The namespace is: root\CIMv2

The query for the PDCe is: Select * from Win32_ComputerSystem where DomainRole=5

 

You do need a reverse policy though so that when the PDCe role is transferred the “old” PDCe switches back to a normal DC.

 

Have a look here:



http://www.jhouseconsulting.com/2014/01/10/script-to-create-group-policy-objects-and-wmi-filters-to-manage-the-time-server-hierarchy-1153

 

Cheers,

Jeremy

 

show

Close